Home > Pkgadd Error > Pkgadd Error Could Not Process Datastream From /var/spool/pkg

Pkgadd Error Could Not Process Datastream From /var/spool/pkg

Contents

Christopher Rabson sent this email: Thanks Steve, I confess that I did not look at the FAQ very closely. Is there an easy way to find out for sure what the most recent patches are?Thanks!John John CraigAlpha-G Consulting, LLCwww.alphagconsulting.com RE: Confused by pkgadd error kHz (MIS) 23 May 06 19:23 They have not been kept anything like up to date. Here's a bit of tcsh script that does the trick, though. -------- set opman = `/usr/bin/ls -dm /opt/*/man | sed 's/, /:/g' ` setenv MANPATH /your/other/man:${opman}: unset $opman ------------ Randall Smith click site

y bash-2.05# pkgadd -d libgnomecanvas-2.4.0,REV=2004.03.14-SunOS5.8-sparc-CSW.pkg pkgadd: ERROR: attempt to process datastream failed - bad format in datastream table-of-contents pkgadd: ERROR: could not process datastream from /mila (0000421) michael 2004-03-21 14:17 Be careful to make copies of any files you may change. Please compare. After more research I have discovered that the BigFix support web site (http://support.bigfix.com/install/besclients-nonwindows.html#solaris), indicates that the Solaris 10 package (SPARC) is the same as the Solaris 9 package (SPARC). http://users.softlab.ntua.gr/~sivann/books/Solaris/soladvsa/ch13/290-293.html

Pkgadd Error Attempt To Process Datastream Failed - Bad Format In Datastream Table-of-contents

Aafaque Shaikh replied Jun 21, 2011 Hello techies.... Re: unable to install cediag Nik Sep 19, 2012 9:18 AM (in response to 963025) Hi. Installing...

Is there a tool that I can use to tell the system to "recrawl" and discover what has been installed? Some specific information can found at: The Pine software Y2K information. Cancel Red Flag SubmittedThank you for helping keep Tek-Tips Forums free from inappropriate posts.The Tek-Tips staff will check this out and take appropriate action. Please turn JavaScript back on and reload this page.

should work.I have only had pkgadd fail when I wasn't in the right directory or didn't specify the right path. Pkgadd No Packages Were Found In Var Spool Pkg Charles Wray replied Jun 20, 2011 You need to tell it that its in that directory pkgadd -d Thanks for your support!

In Solaris 8 or higher, if you want to add a directory to the library search path, you can use the crle command. What is going wrong? connected. Show: 10 25 50 100 items per page Previous Next Feed for this topic FAQ about these packages I have received a lot of questions about the software I have on

Pkgadd No Packages Were Found In Var Spool Pkg

Maybe the package is corrupt . http://www.unix.com/solaris/137702-lost-var-sadm-install-contents-file-var-sadm-pkg.html The large majority of packages install in /usr/local subdirectories, like /usr/local/bin for executables, /usr/local/lib for libraries, etc. Pkgadd Error Attempt To Process Datastream Failed - Bad Format In Datastream Table-of-contents In this case, you need to do mv gcc-3.4.6-sparc-local gcc-3.4.6-sparc-local.gz gunzip gcc-3.4.6-sparc-local.gz pkgadd -d gcc-3.4.6-sparc-local (as root). Pkgadd Error No Packages Were Found In Var Tmp This is the accepted answer.

What I did was I changed the ownership of the file to root and then ran pkgadd -d . command and it worked. get redirected here So what are the solutions? Programs whose executables MUST be placed in a particular directory so that they will work with other programs or the operating system. Q9: I want to install TeX on my system. Pkgadd Solaris

I'll check. Mount the cloned drive's /var partition and manually copy the SUNW? Consider offering them help in making it compliant or offer to pay them or others to make it work for you. navigate to this website Rats.

It is possible that your system might not¬†contain the library you need if you did not install it when your¬†operating system was installed. Mohammed Sadiq replied Jun 21, 2011 Go the directory where the package is and then run #pkgadd -d . Note that some programs want to use the GNU version of ‘as' and not the Sun version.

Resources Join | Indeed Jobs | Advertise Copyright © 1998-2016 ENGINEERING.com, Inc.

Our version is 2.0. mistervernon91 270004W3KC 18 Posts Re: Solaris package installation ‏2011-03-07T22:14:35Z This is the accepted answer. For a one-time relocation, you can use pkgadd -a none filename.pkg 2. I want them in /opt/local/bin or /usr/gnu/bin.

Get the most recent version of the software package you want to use. I think this is one of only a few Solaris boxes on the client's rather extensive campus and I don't think they have any Solaris weenies on staff any more. Q3: I am having trouble trying to get g++ and libg++ working. my review here RE: Confused by pkgadd error JMCraig (Programmer) (OP) 26 May 06 09:11 kHz,Here's the OBP's info:# prtconf -VOBP 3.16.1 1999/04/19 07:55Where can I find out if a given patch is compatible

There are at least four directories that may be used in the pkgadd installation process. This only works for Solaris 8. Romeo Ninov replied Jun 21, 2011 And also will be good to check with file command the type of the file(package) Top Best Answer 0 Mark this reply as the best You might not have to install this package.